Prueba los nuevos drivers de Nvidia para (X)Ubuntu Intrepid

Es decir, los drivers son nuevos pero están hechos para las tarjetas "antiguas" (se siente un dolor al nombrarlas así, más aun teniendo una) que van desde las TNT hasta las Geforce4.

Alberto Milone, el mismo que hizo ver la luz a muchos con su aplicación Envy ha puesto a disposición los últimos paquetes enviados por el equipo de nVidia que funcionan con la nueva versión del X.org que viene en Xubuntu Intrepid.

Para tener instalado estos drivers, si eres de los que poseen uno de los modelos afectados, lo primero es añadir el repositorio proposed a la lista regular de nuestros repositorios en sources.list.

1. Abrimos /etc/apt/sources.list con el editor de textos preferido y añadimos:

deb http://archive.ubuntu.com/ubuntu/ intrepid-proposed restricted main multiverse universe

2. Actualizamos el sistema con
sudo aptitude update

3. Vía Synaptic buscamos los paquetes
nvidia-glx-96 para tarjetas después de la Geforce2 y nvidia-glx-71 para versiones anteriores.

4. Una vez instalado, reinciamos el sistema, debería aparecer la aplicación de configuración de nVidia en el menú del sistema, si al abrirlo muestra como si no estuvieran instalados los drivers tenemos que proceder a editar el archivo xorg.conf.

Una copia del archivo antes que nada:
sudo cp /etc/X11/xorg.conf xorg.conf.bak

Luego abrir el archivo con el editor de textos preferido:
sudo nano /etc/X11/xorg.conf

Y añadir las siguientes líneas en la sección Device, quedando más o menos de esta forma:

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "UseDisplayDevice" "DFP"
Option "AddARGBGLXVisuals" "true"
EndSection


5. Reinicia la PC y ahora si deberías tener aceleración gráfica en (X)Ubuntu Intrepid.

NOTAS:
Añadir los repositorios Proposed usando Synaptic
El post sobre los nuevos drivers escrito por Alberto Milone
La sección en Launchpad donde puedes dar tus impresiones sobre este driver

Parece que hay algunos problemas para los que usan Wine y esta versión del driver pues el texto resulta ininteligible.

Usando la última versión estable de XFCE, la 4.4.3 y activando Composite el texto debajo de los íconos en el escritorio desaparece así como las opciones de menú en Opera, a ver si alguien más puede confirmar este problema.

Compartir
  1. gravatar

    # by kristian - 5 de noviembre de 2008, 16:15

    Muchas gracias compañero!!!! he estado volviendome loco desde que actualizé a 8.10 pq no era capaz de activar los controladores de mi Nvida geforce 400. me encontrë googleando este artículo de casualidad cuando lo daba todo ya por perdido y se solucionó mi problema.Un saludo

  2. gravatar

    # by 3dx - 6 de noviembre de 2008, 16:42

    De nada!!!

    Es bueno saber que personas como Alberto Milone están para hacernos las cosas fáciles a los que usamos Ubuntu, las gracias a él por compilar los drivers en un cómodo paquete DEB.

    Saludos!!!

  3. gravatar

    # by Antonio - 22 de enero de 2009, 5:27

    vaya di con tu blog x azar y me resulto super interesante. no estoy muy metido en esto pero hace 15 dias intente instalar ubuntu 8.10. todo iba de maravilla... pero cuando intente cambiar la resolucion de la pantalla me lleve la sorpresa. mi nvidia no estaba trabajando. despues de seguir varios manuales no obtuve resultado y aunq mis conocimientos son limitados le puse empeño. finalmente volvi a W... ayer vi tu web y me puse a ello de nuevo. todo iba bien mira te describo lo q hice:
    1. sudo gedit /etc/apt/sources.list
    y añado:deb http://archive.ubuntu.com/ubuntu/ intrepid-proposed restricted main multiverse universe
    2. Actualizo el sistema
    sudo aptitude update
    3. Vía Synaptic busco los paquetes nvidia-glx-96
    4. Una vez instalado, reinicio el sistema. la aplicación de configuración de nVidia en el menú del sistema al abrirlo muestra como si no estuvieran instalados los drivers y procedo a editar el archivo xorg.conf.
    hago copia del archivo antes que nada:
    sudo cp /etc/X11/xorg.conf xorg.conf.bak
    abro el archivo con el editor
    sudo nano /etc/X11/xorg.conf
    Y añado las siguientes líneas en la sección Device, quedando asi:
    Section "Device"
    Identifier "Configured Video Device"
    Driver "nvidia"
    Option "NoLogo" "True"
    Option "UseDisplayDevice" "DFP"
    Option "AddARGBGLXVisuals" "true"
    EndSection
    5. Reinicio la PC y ahora supuestamente debería tener aceleración gráfica en Ubuntu Intrepid pero al arrancar me sale este mensaje:

    Cita:
    UBUNTU is running in low graphics mode
    The following error was encountered. You may need
    to update your configuration to solve this.

    (EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
    (EE) NVIDIA(0): ***Aborting***
    (EE) Screen(s) found, but none have a usable configuration

    Pues quizas serias tan amable de decirme donde fallo pues ya no se q probar...
    muchas gracias x tu blog!!

  4. gravatar

    # by 3dx - 22 de enero de 2009, 15:46

    Parece ser que el modelo de tarjeta que tienes no es soportado por este driver, Lo digo por este mensaje:

    Failed to load the NVIDIA kernel module!

    Estos pasos sólo son válidos para tarjetas GForce 4 y anteriores que cuentan con aceleración gráfica.

    ¿Qué modelo de tarjeta tienes?

    En todo caso la salvación está en los foros de Ubuntu en español e inglés.

    Saludos!!!

  5. gravatar

    # by Antonio - 22 de enero de 2009, 15:57

    la version la miro con. lspci
    00:10.0 VGA compatible controller: nVidia Corporation GeForce 7050/nForce 610i (rev a2)
    he probado los tutoriales de ubuntu des cargando cn sinaptyc y cn la consola y tambien descargando desde la pagina de nvidia... me inscribi en el foro pero los consejos no me sirvieron de mucho :( tambien estube cn milone y hice todos los pasos con envyng y me baje el recomendado pero nada de nada,... tambien me meti en
    espaciolinux.com y deje un mensaje hace un par de dias y 0 respuestas... q pena y la cosa es q no quiero volver con W... bueno he puesto a descargar Fedora 10. ya no se q hacer, a lo mejor lo tengo delante de los ojos y no lo veo. bueno de todos modos muchisimas gracias x interesarte. un saludo

  6. gravatar

    # by 3dx - 22 de enero de 2009, 22:41

    Este tutorial no te servirá para el modelo que usas, tienes una Geforce 7, intenta probar instalando los drivers nvidia-glx-173 o de números más altos. Prueba una vez más con Envy, primero elimina todos los rastros de instalación mediante las opciones de Envy y luego vuelve a instalar.

    Este no es un error de Ubuntu o Linux, es de los drivers de Nvidia y la última versión del X.org que es la 7.4, hay unos conflictos que impiden la aceleración gráfica. Si nada de esto de funciona, sugiero que cambies a la versión anterior de Ubuntu, la 8.04 que tiene soporte por 3 años y usa la versión anterior del X.org que no tiene conflictos con los drivers de Nvidia.

  7. gravatar

    # by darkblacky - 14 de marzo de 2009, 16:47

    yo he usado los drivers 96 y 71 en ese orden y con ambos me da el error que mencionan mas arriba

    Cita:
    "UBUNTU is running in low graphics mode
    The following error was encountered. You may need
    to update your configuration to solve this.

    (EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
    (EE) NVIDIA(0): ***Aborting***
    (EE) Screen(s) found, but none have a usable configuration"

    Adjunto resultado del comando para la interfaz.

    darkblacky@darkblacky-desktop:~$ lspci | grep -i vga
    02:00.0 VGA compatible controller: nVidia Corporation NV15 [GeForce2 GTS/Pro] (rev a4)


    salu2.
    PD. con fedora me pasaba casi lo mismo, se activo por una vez la tarjeta de video, una vez realizado un cambio se volvio a colocar por defecto en 640x480, asi q me cambie esperando solucionar los problemas de video y no he podido ..

    salu2, seguire intentandolo ....

¿Algún enlace roto? Deja un comentario

Broken link? Leave a comment

Blog Widget by LinkWithin